
 1 

Editing images with Gimp. 
 

1. Installing and opening Gimp. 

Download and install the latest version of Gimp from www.gimp.org 

Start Gimp – this can take a while! When you start, everything will look confusing - do not panic, take a 

deep breath. 

When you first open Gimp, you should see something like this - 

 

 

 

There are 2 ways to interact with Gimp—multiple window mode, and single window mode.  You can 

switch between them by going to the Menu Bar > Windows > Single Window Mode.  Unless you’re 

working with two images at the same time, e.g. to merge them, I suggest you use Single Window Mode 

(make sure the box has a cross in it). 

 

2. Importing images. 

If you have a large enough screen then as well as having Gimp open, you can open the folder containing 

the images you wish to edit.  You can click and drag an image directly into Gimp. 

If you don’t have enough room on screen to open the folder, then on the Menu Bar go to File > Open, and 

navigate to the folder containing the images, and open the one you require. 

 

 

Toolbox—if absent, 

press Ctrl+B 

Workspace 

Layers/Brushes dock 

—if absent, press 

Ctrl+L 

file:///C:/Users/robbo/Desktop/www.gimp.org
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3. Rotating images. 

Does the image require straightening?  I.e. is it leaning to the right or left?   

If so, select the Rotate Tool from the Toolbox and click on the image. 

Clicking the up or 

down arrows in the 

Angle box will rotate 

the image clockwise 

or anticlockwise.  

Once you think it is 

straight, click Rotate.    

If you need help telling 

whether or not the 

image is straight you 

can insert guides. Click 

inside the ruler on the 

left and drag across—a 

blue dotted line will 

appear. Position this 

close to a vertical edge 

of the image and rotate 

until they are parallel. 

Then click Rotate. 

You can also drag down guides from the top ruler.  You can drag as many guides as you require.  If you  
 
want to get rid of a guide, select the Move Tool  from the Toolbox , click on the guideline  
 
(it should turn red), and you can then drag it off the workspace. Alternatively, go to the Menu Bar > 

View > Show Guides and uncheck the box (you will have to turn it back on again if you want to use 

guides again in the same session). 

4. Changing perspective.  

Sometimes, especially when digitising photographs, you are working with images shot from above or 

below, or one side.  Whilst the original master image should never be manipulated, it is permissible to 

edit an image destined to be published on the web, to make it more closely resemble the actual object 

itself.   
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Select the Perspective Tool  from the Toolbox, and click on the image. 

Remove the guidelines to make the workspace clearer. 

Insert 4 guidelines to 

frame the image of 

the object you wish 

to correct using 

corners or significant 

reference points etc. 

The image might be obscured by 

the Perspective Tool dialogue box, 

but you can move this by clicking 

on the underlined up arrow in the 

box. 

Click and drag within the image, 

near the corners, until the 

reference points on your image 

line up with the corners of the 

blue dotted guidelines cage.  

Click Transform in the Perspective 

Dialogue Box 

5. Cropping images. 

Select the Crop Tool  from the Toolbox, and click on the image. 

Use the Crop Tool to cut away any part of the original image that is not part of the object itself (in the 
case of photographs of objects, leave a narrow border around the object, if you are digitising the whole 
photograph and it has a border, keep the border).  
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Position your cursor on the corner of the image where you want to start the crop and click and drag 

diagonally to where you want the crop to end. Release the mouse button (if you’re using a mouse!)  

 

You can now commit to the crop by clicking inside the crop box, or abandon it and start again by clicking 

outside it.   

 
You can fine tune the crop by 
moving the cursor to the in-
ternal edges or corners of the 
crop box and clicking and 
dragging them.      

6. Scaling (resizing) images. 

Go to the Menu Bar and select Image > Scale Image. 

In the dialogue box, 

change whichever is 

the largest dimension 

to 1300. 

Change X to 72. X and 

Y are normally linked, 

so changing one  will 

change the other. 

Click Scale. 
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7. Obscuring personal details. 

When you are editing documents such as letters , etc. you may want to obscure personal details be-

fore the image is published on the web.  These may include, but not be limited to, address, tele-

phone number, fax number, and email address.  JHASW does this if the image is less than 50 years 

old. 

To do this we use the Smudge Tool. It is simpler to Smudge after resizing, and before in-

serting the border or logo. 

Double click on the 

Smudge tool icon and 

the Tools Options box 

will open.  The Brush 

will default to whatever 

you used last.  If it 

doesn’t look like this, 

click on the icon next to 

Brush and select the 

middle fuzzy circle.  Set 

the size to 20. 

Click to one side of 

whatever you want to 

smudge, press Shift and 

drag across.  Click where 

you want to finish and 

release Shift. 

You can drag freehand, 

but using Shift ensures a 

straight line. 

8. Inserting a border. 

Go to the Menu Bar and select Filters > Décor > Add Border 

Change the first two 

boxes from 12 to 50, 

and the last box from 

25 to 1. 

Right click in the 

Border color box and 

select black. 
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At this point you should check that there is a clean line between the edge of the image and the 

border.  If there is a gap, or void, you may want to undo the Border (press Ctrl+Z) and re-do the 

Crop, and then re-do the Border. 

To see the resized image more clearly, you can zoom in and out using the plus and minus keys on 

the keyboard. 

Once you have changed the Border defaults, they will stay in force for the active Gimp session.  If you 

close Gimp and re-open it, next time you insert a border you will have to reset the parameters to the 

required settings. 

9. Inserting and positioning a logo. 

This works far better if you copy the logo to your desktop as then you can just click and drag it onto the 

image in Gimp (if you are working in full screen, you will obviously have to resize Gimp so that the logo is 

visible). 

Only insert your organisation’s logo into images for which you own the copyright. 

The logo will automatically be placed in the centre of the image. JHASW positions it in the bottom right 

hand corner. 

Double click on the Alignment Tool and a new dialogue box will appear. 

Click on the logo to 

select it, then click on 

the Move to Right 

button, then the 

Move to Bottom 

button. 

The logo should now 

be at the bottom 

right corner of the 

image. 
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10. Exporting the image. 

Go to the Menu Bar and select File > Export As 

Do not change the 

name of the image, as 

you want the web-

ready name to 

correspond to the 

master name. 

‘Save in folder’ 

defaults to the folder 

where the master 

image is located, but 

creating a new folder 

will make life easier 

for you.  

Click on Create Folder 

- give the folder the 

same name as the 

original folder, but 

change Master to 

Web-ready. Press 

Enter/Return. 

Go back to the Name 

field, backspace over  

tiff, and enter jpg. 

Click Export. 

[When you export 

the next image 

remember to select 

the new folder from 

the drop down list.] 

Set the Quality to 50, 

then click on Save 

Defaults to save you 

having to do this 

every time. 

Click on Export. 
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Click here to finish 

working with this 

image. 

In the Close dialogue box, select Discard Changes as you have already saved a jpg version of the image and 

don’t want to change the master. 

11. Joining images in Gimp. 

There may be instances where the document you are digitising is too large to be scanned in one pass.  In these cases it may be 

necessary to scan the document in parts and digitally stitch them together afterwards. 

The example here shows how to join two images together, but the same process can be used to join more.   

Wherever possible try to retain the same orientation of the document on the scanner as this reduces potential tone differences 

from light leaking into the scanner from the side. 

This process is easier if you use Gimp in non-Single Window mode. You can toggle this on and off in the Menu Bar by going to  > 

Windows > Single Window Mode.  The box needs to be checked. 

 

The following instructions assume that you are already familiar with basic Gimp processes such as Rotate, Crop etc. 

Select both images and drag them into Gimp. 

You should be able to see thumbnails of both images in the top left of the workspace. You can toggle between the two by 

clicking on them. 

It makes life easier if both images are straight, so sort this out before you do anything else. 

Decide which image is going to be the main one and click on the second to start editing it. 

Before you select the area you need to copy, have a think about how easy it’s going to be to line this up with the other part of 

the document.  It may well be easier to position the edge of your crop in a part of the page where there is no text, or along a 

pre-existing line on the document.  If this is not possible then try to place the crop mark so that it crosses as little text as 

possible. 

Using the Crop tool, select which part of the second image you will need to copy, and when you’re happy with the selection, 

click inside it to finalise it.  Copy it to the clipboard by pressing Ctrl+C. 

Toggle to the other image. 
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You now need to paste from the clipboard to the main image, 

but you need to enlarge the Canvas Size first, otherwise there 

will be nowhere for the image to be pasted except on top of 

the main image. 

On the Menu Bar go to Image > Canvas size > 

Increase Width or Height, depending on where you want to 

paste (i.e. at the top/bottom, or at the side).  I usually double 

the existing measurement to make sure I have plenty of room.   

 

You should now see a checked extension to your main image. 

Press Return – this will show you where the main image will be 

placed on the new canvas.  You can click and drag it if 

necessary.  Press Resize. 
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Now paste from the clipboard, but you need to paste as a new 

layer. On the Menu Bar go to Edit > Paste as > New Layer. 

The new layer should be pasted on to the middle of the main 

image [not shown].  You can now use the Move tool to click and 

drag it into roughly the correct location. 

To get the pasted layer to overlay the main image as closely as 

possible, you can change the transparency of the pasted layer 

so that you can see through it. 

The Layer dialogue box should already be open. Make sure the 

pasted layer is selected and change the Opacity to 50%.  You 

should now be able to see both layers at once.  You can zoom in 

and use the Move tool and arrow keys on the keyboard to 

ensure that the two images match up as closely as possible. 

When you are happy, stop. You will never be this happy again. 

Pause and savour the moment. Then change the image Opacity 

back to 100%. 

Now you want to merge the layers. On the Menu Bar go to 

Layer > Merge down. 

Happy?  Good.  Now change the canvas size to match the 

layers.  Go to Image > Fit Canvas to Layers.  This should get rid 

of the surplus checked area. 

If the two scans were not originally aligned exactly then you 

may have to do another crop to get rid of the checked  ‘dead’ 

area. 

At this point it’s probably a good idea to save the merged image 

as a TIFF master. Call it by one of the original file names, with 

an “m” after it. 

You can now proceed with creating the web-ready version as 

usual. 
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12. Keyboard shortcuts and tips. 

If you are happy to use keyboard shortcuts, some of which are built into Gimp and some of which 

you can create yourself, then some of these processes can be completed a lot faster; this is particu-

larly true if you are performing the same processes on a batch of images. 

On the Menus Bar select File > Keyboard shortcuts. 

Clicking on the plus 

signs open up further 

choices. 

Select the action for 

which you wish to 

create a shortcut, 

and enter your 

keystroke 

combination in the 

New Accelerator 
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As usual Ctrl+Z undoes the last action, and Ctrl+Y re-does the last action. 

Using keyboard shortcuts may seem fiddly at first, but once you get used to it, it can significantly speed up 

part of the editing process (especially if you are not using a mouse). 

Creating shortcuts for File > Export As; and Image > Scale Image, is useful – I use Ctrl+X and Ctrl+S 

E.g. to resize a portrait image, Ctrl+S > Tab > Tab > enter 1300 in the Height box > Tab > Tab> enter 72 in 

the X Resolution box > Return > Alt+S 

Ctrl+F will repeat the last special action, e.g. inserting a border, so if you inserted a border on the last im-

age you worked on and haven’t executed any special action since, Ctrl+F will now insert a border. 

E.g. to export a file, Ctrl+X > double click on your destination folder > do the backspacing to change the 

filename extension > Return > wait for the other dialogue box to open and Return again.  

 

 


